Murga

個人的に言いたいコト・主張・気持ち。

リーダブルコード

data とか info とか list とか item とかいう変数名止めろ

currentData itemInfo dataList とかなんとかいうダッサイ変数名マジで止めろ。 ただ単に「ネーミングセンスがダサい」という話では留まらず、実際に悪影響を及ぼすネーミングだから、止めるべき理由と、止め方・改善方法を教える。 何が悪いの? コード例 …